Project

General

Profile

Actions

Bug #229

closed

Android App crashes immediately on startup

Added by Maximilian Stein about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
04/25/2013
Due date:
% Done:

0%

Estimated time:
Build Version:

Description

Android App crashes immediately on startup without any readers attached nor user input. The activities start to be displayed and one can see the first time configuration dialog for some milliseconds, then the app closes without error messages.
This bug appears in SNAPSHOTS from master and stage branches after tag 1.0.1. At least the latest revision is affected. Tag 1.0.1 build works correctly.

LogCat output:
...
W/System.err(17164): java.net.BindException: bind failed: EADDRINUSE (Address already in use)
W/System.err(17164): at libcore.io.IoBridge.bind(IoBridge.java:89)
W/System.err(17164): at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:150)
W/System.err(17164): at java.net.ServerSocket.<init>(ServerSocket.java:100)
W/System.err(17164): at java.net.ServerSocket.<init>(ServerSocket.java:69)
W/System.err(17164): at org.openecard.android.TCTokenService.run(TCTokenService.java:56)
W/System.err(17164): at java.lang.Thread.run(Thread.java:856)
W/System.err(17164): Caused by: libcore.io.ErrnoException: bind failed: EADDRINUSE (Address already in use)
W/System.err(17164): at libcore.io.Posix.bind(Native Method)
W/System.err(17164): at libcore.io.ForwardingOs.bind(ForwardingOs.java:39)
W/System.err(17164): at libcore.io.IoBridge.bind(IoBridge.java:87)
W/System.err(17164): ... 5 more

Actions #1

Updated by Dirk Petrautzki about 10 years ago

  • Assignee set to Dirk Petrautzki
Actions #2

Updated by Dirk Petrautzki about 10 years ago

  • Status changed from New to Review
Actions #3

Updated by Detlef H├╝hnlein about 10 years ago

  • Reviewer set to Maximilian Stein
Actions #4

Updated by Tobias Wich about 10 years ago

  • Target version set to 1.1.0

@Dirk: Does this also apply to 1.0.2?

Actions #5

Updated by Dirk Petrautzki about 10 years ago

This is an aftereffect of the other startup fixes and therefore needs to be included in the 1.0.2 release.

Actions #6

Updated by Tobias Wich about 10 years ago

  • Target version changed from 1.1.0 to 1.0.2
Actions #7

Updated by Tobias Wich about 10 years ago

  • Status changed from Review to Closed
Actions

Also available in: Atom PDF