Project

General

Profile

Actions

Bug #803

closed

Cannot reproduce tests with eID TestBed clients

Added by Michele Adduci over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Target version:
Start date:
04/20/2020
Due date:
% Done:

0%

Estimated time:
Reviewer:
Build Version:
1.4.1

Description

I'm running open eCard 1.4.1 on Ubuntu 18.04 and using the eID TestBed client (https://github.com/eID-Testbeds/client) with PersoSim.
All the required configurations are working, including the import of certificates in the eCard client "cacerts" file, but I'm continuously getting internal errors (return code: 80) when trying some test cases.
Another interesting error occurs when detecting proxy settings: in the app, it's always assumed that a Firefox installation is present (see logs).

Would it be possible to make the tests reproducible, since open eCard is certified after BSI TR-03124?


Files

richclient_info.log (131 KB) richclient_info.log Michele Adduci, 04/20/2020 03:38 PM
ics_20181129.xml (8.43 KB) ics_20181129.xml Tobias Wich, 04/30/2020 03:14 PM
Actions #1

Updated by Tobias Assmann over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Tobias Assmann

Hello Michele,

thanks for your interest in the OeC.
Please let us know, which TestCases fail exactly. Then I can try to reproduce this issue.
Regarding the FF installation, this is one possible proxy setting which is tried to determine the proxy settings on the system.

Best Regards
Tobias

Actions #2

Updated by Michele Adduci over 1 year ago

Hello Tobias,

thanks for your feedback. Basically, the only successful tests are the ones triggering the UI status (e.g. Show UI About, Change Pin dialog) and the ones checking if TLS Certificates are correct. All the other test cases/Modules are failing and the failure looks like the ones in the attached log file in my first message.

I think I've followed all the steps properly as cited in the operators manual and the change PIN operation works finely with PersoSim, so I believe something is missing.

Actions #3

Updated by Tobias Assmann over 1 year ago

  • Status changed from In Progress to Rejected

Hello,

Please try to add this to your /etc/hosts file:

127.0.0.1 tr-03124-browsersimulator.secunet.de
127.0.0.1 eidserver-1-idp-test.secunet.de
127.0.0.1 eidserver-idp-test.secunet.de
127.0.0.1 tctokenprovider-idp-test.secunet-nsop.de
127.0.0.1 eservice-idp-test.secunet.de
127.0.0.1 eservice-idp-test.secunet-nsop.de
127.0.0.1 redirect-1-a-idp-test.secunet-nsop.de
127.0.0.1 redirect-a-idp-test.secunet-nsop.de
127.0.0.1 redirect-1-b-idp-test.secunet-nsop.de
127.0.0.1 redirect-b-idp-test.secunet-nsop.de
127.0.0.1 redirect-1-c-idp-test.secunet-nsop.de
127.0.0.1 redirect-c-idp-test.secunet-nsop.de
127.0.0.1 commerroraddressserver-idp-test.secunet.de

This seems to be an issue with the testbed.

For further investigation I would recommend you contact secunet, as they provide this software.

Best regards

Tobias

Actions #4

Updated by Michele Adduci over 1 year ago

Hi

thank your for the reply.

I've added almost all of them for my test, apart from

- eidserver-1-idp-test.secunet.de
- redirect-1-a-idp-test.secunet-nsop.de
- redirect-1-b-idp-test.secunet-nsop.de
- redirect-c-idp-test.secunet-nsop.de

Those above are not mentioned in the Guide, but also with the missing ones, nothing changes.
I will try then to contact Secunet, but it would be useful also to see which kind of profile for the testbed (ICS.xml - where all the properties for the tests are stored) was used for the certification of open eCard.

Kind regards and many thanks again

Actions #5

Updated by Tobias Wich over 1 year ago

I attached the ICS that was used for the certification of the mobile SDK.

Actions #6

Updated by Michele Adduci over 1 year ago

Hi Tobias

Many thanks!

Actions

Also available in: Atom PDF