Project

General

Profile

Actions

Bug #167

closed

Transmit is aborted if CommunityIdVerification fails

Added by Sebastian Lösch over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/24/2013
Due date:
% Done:

0%

Estimated time:
Reviewer:
Build Version:

Description

In case the CommunityIdVerification fails, the Tansmit is aborted.

ResultMajor: http://www.bsi.bund.de/ecard/api/1.1/resultmajor#error
ResultMinor: http://www.bsi.bund.de/ecard/api/1.1/resultminor/al/common#unknownError
ResultMessage: State of non-volatile memory changed. No further information given. (Code: 6300)

Actions #1

Updated by Sebastian Lösch over 9 years ago

  • Subject changed from Transmit is aborted when CommunityIdVerification fails to Transmit is aborted if CommunityIdVerification fails
Actions #2

Updated by Tobias Wich over 9 years ago

  • Status changed from New to In Progress
  • Assignee set to Tobias Wich

The problem is that the Transmit code is handling empty $AcceptableStatusCode$ elements as if only the code 9000 was specified. Now in case nothing is specified and the card returns 6300, the IFD must proceed normally instead of breaking execution and returning an error.

Actions #3

Updated by Tobias Wich over 9 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF